Scratch not present in the main menu

Hello there,

I have just re-started my son’s Poppy Ergo Jr. It stayed in a box for quite a while (meaning many years) because the Pixl card was burnt. I recently ordered a new one and powered it up. All seems to be working (I connect through the IP address, wired connection directly to my router) but I noticed that scratch is not available in the main menu anymore. I am pretty sure that it was back then as my son was playing with it. Not sure what had been done back then as my son is not a child anymore and doesn’t remember but his younger brother (8 yo) would be happy to play with it.
How could I get scratch re-appear in the menu? I tried the “Upgrade your robot software” in the “Configure your robot” section but nothing happened (it is connected to the internet as I successfully ran apt update through ssh).

Hello @Pikko, on the top right corner we can see that you are using software v1.0. Scratch was not available in that present, upgrade to the latest image: Download and burn the system image · Documentation of the Poppy Platform

Thank you alex38,

I had it figured out, installed the latest image and now everything is fine.

You’re welcome, I’m glad it worked :slight_smile: