Error installing poppy-ergo-jr software

I’m trying to install poppy-ergo-jr software.
I’ve installed Anaconda Mini 64 bit, then numpy, scipy, ecc… and all was ok.
Then I’ve tried to do this from Anconda prompt:
pip install poppy-ergo-jr

but I retrieved this error:
File “c:\users\nicola~1.bis\appdata\local\temp\pip-install-qqjo7o\ikpy\”, line 16, in
with open(path.join(this_directory, ‘’), encoding=‘utf-8’) as f:
TypeError: ‘encoding’ is an invalid keyword argument for this function

Someone can help me?

which version of python are you using? for me it works fine with python 3.6, python 3.7 and python 2.7 give me errors.

Yesterday I tried with Pithon 2.7 and it gave me the error. Now I’ve installed miniconda3 with Python 3.7 and it works!..BUT
when I create a new PoppyErgoJr instance to go with the web-simulator (or vrep) I have now this error:

from pypot.creatures import *

jr=PoppyErgoJr(simulator =‘poppy-simu’)
Traceback (most recent call last):
File “/home/nicola/miniconda3/lib/python3.7/site-packages/ikpy/”, line 98, in
chain = list(next(it) for it in itertools.cycle(iters))

I need some help…

yeah that’s the issue I had with python 3.7 as well, python 3.6 worked for me. Could you try again, using python 3.6 instead?

Oh …Yes! I’m going to try as soon as possible! Thanks!!!

No problem! From what I’m reading, a change in python 3.7 on how generators behave is causing problems.

I haven’t tried this, but a quick fix seems to be to change in the code the line

raises StopIteration



it works with python 3.6!!!
I’m so happy! Thanks a lot!

1 Like

Awesome! Glad to be of help.

1 Like