Anaconda and simulation

I ve made a tuto for my student to install the ergoJR simulation
It seems something change …Iv got a new computer and i try to install the simulation of the robot …

Computer W10 64B Pro
Anaconda Install Anaconda3-5.1.0-Windows-x86_64.exe OK
Test Hello world on spyder OK

With the new version you have to install some modules
I use now Anaconda promp Execute as admin

Command :
pip install pyserial

I’s OK

conda install -c conda-forge bottle

It’s OK

pip install pypot --user -U --no-deps

Its OK

pip install poppy-creature --upgrade --no-deps

It’s OK

pip install poppy-ergo-jr --user -U --no-deps


Now I run python and test
from pypot.creatures import PoppyErgoJr DOESN’T WORK

I tried
from pypot.creatures import * witch is OK

But then
robot = PoppyErgoJr(simulator=‘poppy-simu’, use_http=True) does’nt work

what can i do ?

Thanks for your help !

it’s strange, everything seems ok, but it does not work!
So, no one on the team will have time to explore the problem until next week. :confused: Sorry