Poppy Ergo Jr cannot be simulated in Vrep

I followed the installation instructions described here : https://docs.poppy-project.org/fr/installation/install-poppy-softwares.html

      • I installed bonjour
      • I installed anaconda for win 64 bits (PATH and default Python were checked)
      • In the anaconda invite, I wrote: pip install poppy-ergo-jr
      • I installed vrep pro v4.0.0

To test,

  1. I launch vrep
  2. I wrote poppy-services --snap --vrep --no-browser poppy-ergo-jr

I received the error message: No installed poppy creature were found!
you should first install the python package corresponding to your robot or check your python environment

Then I installed poppy humanoid with the command pip install poppy-humanoid.
To test, I wrote poppy-services --snap --vrep --no-browser poppy-humanoid and the robot was created and running in vrep! (after checking the box 3 times on the vrep sim)

I tried again poppy-services --snap --vrep --no-browser poppy-ergo-jr
I received the error: argument creature: invalid choice: ‘poppy-ergo-jr’ choose from ‘poppy-humanoid’).

The command pip search poppy sends the following results:

  • poppy-creature 2.0.0 INSTALLED
  • poppy-humanoid 2.0.1 INSTALLED
  • poppy-ergo-jr 2.0.0 INSTALLED

If I open a juniper notebook and I type (https://github.com/poppy-project/community-notebooks/blob/master/tutorials-education/poppy-humanoid_poppy-torso__vrep_installation%20et%20prise%20en%20main/poppy%20simulé/Ergo_simulation%20prise%20en%20main.ipynb):

  • from poppy_ergo_jr import PoppyErgoJr
  • creature = PoppyErgoJr(simulator=‘vrep’)
    I have the error: ImportError: No module named URDF_utils from from ikpy.URDF_utils import get_chain_from_joints in D:\software\Anaconda2\lib\site-packages\pypot\creatures\ik.py in ()

If I type

  • from poppy.creatures import PoppyHumanoid
  • poppy = PoppyHumanoid(simulator=‘vrep’)
  • poppy.head_z.goto_position(-45, 2)
    the poppy humanoid robot moves its head.

Do you know why everything looks fine for poppy-humanoid but not for poppy-ergo-jr?
Thanks for your help

Hello @GuillaumeG,

ikpy has been updated lately and Poppy robots have not yet patched. Could you install ikpy==2.3.3 in your environment?

poppy.creatures is deprecated and will soon been dropped. It must be replaced by pypot.creatures or an import from the robot package from poppy_ergo_jr import PoppyErgoJr

As for V-rep, the V-rep support hasn’t been upgrade for a while. I’m unsure of the stable or unstable feature in the software version available in pypi.

Thanks @Yoan! Downgrading ikpy to version 2.3.3 solved the issue. It is working fine on Coppelia Sim (formerly V-rep) now.

1 Like