V-REP Setup Problem

I am trying to set up a simulation of the Ergo Jr. with V-REP, and I got through the installation of V-REP without any problems (as far as I can tell) by following the instructions on the Poppy website, but I hit a problem on the Test your installation section. I opened V-REP and the Anaconda Prompt and typed

poppy-services --snap --vrep --no-browser poppy-ergo-jr

like it said to, but instead of giving me the error message the site said it should, I got this:

A model of the robot showed up in V-REP, but as far as I can tell I can’t do anything with it, and when I try to keep on following the steps to control it with Jupyter it doesn’t work.

hey @uniqueusername

so it’s strange… maybe you can test through Ipython notebook such as https://github.com/poppy-project/community-notebooks/blob/c0a4167c92fc2718cea1590ae5bd71dede5e4996/demo/poppy-humanoid_Controlling%20in%20V-REP%20using%20pypot.ipynb
just adapte for use snap on ErgoJr: add
in paramter of
poppy = PoppyHumanoid(simulator='vrep')
from pypot.creatures import *
poppy = PoppyErgoJr(simulator='vrep', use_snap=True)

I just tried your suggestion and I got the same error message, albeit with a few extra lines of code beforehand. According to google the error has something to do with how the computer is processing text files, but I don’t know why that would be.

hey @uniqueusername

so it still strange for me but I think, I have a trick!
go to this file:
and edit at line 166: replace
set_snap_server_variables(find_local_ip(), port, path=get_snap_user_projects_directory())
set_snap_server_variables(find_local_ip(), port, path=None)

try it and tell me

hey @uniqueusername

Have you try my patch? It works ?

Sorry I didn’t reply sooner, I haven’t had my computer for the past week. It worked perfectly. Thanks for the help.

1 Like