Problems to id the dynamixels


The Cherry Team had received two new Poppy Torso and I am assembling them. But I have some problem to id the motors.
I try using Herborist, but when I start the scan, well, nothing happen, not even the scan…
So I try to use Robotis’s software, Robot wizzard.
Work fine appart from the fact that it does not detect the motors. I try to update the USB2AX’s pilot as explained here :
and to plug the USB2AX to different usb port.
But it is still unable to detect the motors.
Anyone have any idea of what can be wrong ?
Thanks for your help,

did you:

  • check that your USB2AX is detected (in the device manager)
  • power your motors (USB2AX does not deliver enough power)
  • connect only one motor at a time (several motors with the same ID may confuse the softwares)


Otherwise, please specify your OS and take a picture of the whole stuff if you’re not sure of the montage.

The motor is properly powerered and only only one dynamixel is connected. The montage is ok, we had done this earlier this year with our first robot and I checked with my coworkers. But back then Herborist was still working.
The pilot of the USB2AX is correctly installed but I am not sure the device is properly detected… Got the same problem on my personal computer…

ok then…

Could you try this code:

import pypot.dynamixel

ports = pypot.dynamixel.get_available_ports()
if not ports:
    raise IOError('no port found!')
print 'ports found', ports
for port in ports:
    print port
    dxl_io = pypot.dynamixel.DxlIO(port, baudrate=57600)
    print "scanning"
    found =  dxl_io.scan(range(60))
    print found

alright I got this:

It cannot establish communication with the motor… Just to be sure here a picture of my montage (only one motor is connected and they are not connected together).

It is strange you cannot connect with Robotis Wizard.
Have you tried different communication rates (56K and 1M) ?
Is it the first time you use these servo ? Are they just from the box ?
What is the version of your USB2AX ?
Have you another USB2AX to test if the issue is from USB2AX ?
I see you have 3 COM ports. Have you tried to disconnect the other devices connected ?
And last question : have you tried to change the wires ? When you connect the power, do you see the LED of the servo switch on ?

I made the research for every baudrate. And I update USB2AX so I should have the latest version. I got the same problem before and after the update. I try with all the available ports too.
I tried all the manipulation on two different pc with the same results.
When plugged all the led switch on.

I only have this model of USB2AX and the dynamixels are new (I try with different one too).

Our group had been using a poppy torso for several monthes and we had to built it too.

Is it possible to come use one of your computer to id our motors ?
My internship is coming to an end and I need these robot finished before. If it is possible for you, I can come whenever it is better for you (when a machine is free : lunchtime, evening).

Please, it would be a big help.

Vient quand tu veux à l’INRIA, on essayera de te donner un coup de main.

Laura, did you fix it?
I have the same problem.

Hi, it was a long time ago I don’t remember exactly what we did.
But I had to get help from the Inria Team and I think we had to completly reinitialize the Dynamixels.
Sorry I cannot help more. If you contact the Poppy team they should be able to help.

Laura, thanks for your answer.

@Theo it’s a job for you :wink:

Dear @Theo,
I have the same Laura’s problem. We built our Poppy Humanoid and everything it was working (Using ROS with dynamixel motor package and Python with PyPot library). However, from one moment to another, the servos stopped being recognized. I used the Robotis Wizard and the motors were not found. The funny thing is that individually the motors are detected (using Robotis Wizard). Nevertheless, when I connect them in series no longer.
All of them are set in 1Mpbs and with different ID.
Can you help me?

Thanks for your time!


did you update your servo to the last version ? (You should not).
What was changing just before the servo stopped recognizing ? It was a long time ?

No, I did not update the servos. The version of the firmware is 39 for the MX28AT and MX64AT servomotors and 24 for the AX12, all with Protocol 1.0.
I used the robot on Wednesday and everything was working. The next day, Thursday, the problem happened. I did not perform any changes in the experiment setup or in the firmware/software.
At this moment, Robotis Wizard on Windows 10 detects the motors individually (except one MX28). When they are connected (for instance, only the left arm motors, i.e., 4 motors only), Robotis Wizard does not find the motors.

I tried to do a recovery firmware, but the software does not find any motor in this option. I used this tutorial (

In addition, I tried using Windows 10, Windows 7, the USB2dynamixel, USB2AX (both with the drivers installed, where they are detected by Windows as COM3 and COM5).

Ok, did you try to connect all the motors except the MX28 who does not want to connect ? Sometimes, only one vicious motor contaminates all the chain.
Try to connect “only right arm” or “only right leg” … I suspect one motor is bad.
Which MX28 does not work ?

The motor MX28 that it is not being recognized is in the right arm. In the left arm, all motors are detected individually but are not when plugged in series.

In this video I show the problem

Ok cool the video.
Maybe try to change the cable or check it is well connected between 41 and 42.
Otherwise, replace the 42 motor by another one (ankle for instance)

@Thot Thanks for your time.

I checked the cable and it is working. Dynamixel wizard detects the motor 41 using both cables plugged in that motor. I plugged the motors 43, 44 and 41, and they were not recognized.
In this moment, both legs, and only 4 of 5 motors of the torso are detected when plugged in series.

In addition, I tried to perform a recovery manager (video attached) , using one motor at time as indicated by Robotis. However, the motor were not recognized.

When I plugged both legs, 4 of 5 motors of the torso and the motors 43 and 44 of the left arm, only two MX28 servos were recognized. I realized that they appear with different symbols. One of them is green with a red arrow. The other is black. What this means?