Can't open poppy.local on ODROID-XU4 REV 0.1 20151201

I’m assembling Poppy Torso and I installed pre made ISO image on SD card 10 class, but poppy.local not opening on my PC. When I did the same thing with Ergo Jr, everything was going well.
The blue LED is blinking twice periodically. After 30 seconds fan stops.
What should I do to check the problem?

Did the Odroid get an IP address ? You can use Fing Android application to monitor hosts on your local network.
If the Odroid is connected, can you connect to it in SSH (ssh poppy@poppy.local password=poppy) ?

I can connetct but can’t enter the password, it’s blocked to tap.

Yes, it has IP.

So, what should I check now?

“blocked to tap” ?
Do you know that when you type password, nothing is displayed and it is a feature, not a bug ?

Your IP address 169.254.x.x is in the APIPA range, it is an auto-assigned address. Is you robot connected to a router or directly to your computer ?

ssh poppy@poppy.local is connected.
We connected it directly.
But popply.local still not working.
What we need to do?

1 Like

We connected monitor and keyboard to the Odroid.
On screen we see desktop, everything is working, but poppy.local still not opening.

1 Like

I connected poppy to WIFI network with global network connection and now poppy.local opens. But why poppy.local is not opening when connected directly?

1 Like

I also encountered IP address issues with my Netgear router. The problem was after setting up everything properly I was unable to open the web browser. Could not understand why it happened. Can anyone tell me what is the main problem behind this?

I also connected to my Odroid-XU4 via ssh odroid@<IP_address> and then ssh poppy@poppy.local. It’s also connected to the internet via ethernet-to-router (my local computer is also connected to the same router).

I connected the Odroid to a mouse, keyboard, and monitor, but I still cannot open poppy.local in a Chrome browser from the Odroid. I can from my local computer’s browser, but even then there are problems because I still can’t access the Snap! server or the Jupyter Notebook server.

I have followed the installation guide for a tangible robot using the install scripts for an Odroid-XU4 (using a microSD as the boot drive) at least a dozen times now. I’ve also followed the instructions for downloading Poppy Software (Poppy Humanoid) onto my laptop (Ubuntu 18.04) using both methods - 1) using Anaconda2 / Miniconda2 and 2) via source (in separate tries and not at the same time). I’ve written down every step I’ve taken.

The install instructions are quite confusing and seem very out-dated…when I get to installing the scanning software in the GitHub repo “Assembly Guide > Addressing Dynamixel” it says that Herborist is installed in the user’s PATH if they installed it using the script (otherwise, the user can access the script via the folder in $PYPOT_SRC/pypot/tools/herborist).

Another thing the user needs to run Herborist is PyQt4…BUT YOU CANNOT simply sudo pip install pyqt4…PyQt4 requires SIP, which is provided as a source distribution and binary wheels from PyPi. The online resource (above) says to download sip via pip install sip, however, this does not work since the sip module requires Python 3.5+…I’m using Python 2.7 as per the explicit recommendation from the guide…

So how am I suppose to access Herborist???