Using Camera in Primitives, Ergo JR


I’m using a Ergo Jr and i wrote the code to do a behaviour in a loop primitive but when i ran the primitive in poppy monitor, the camera didn’t turn on, so the camera frame is always a zero matrix.

Any help to turn on the camera in monitor mode?


I solved changing the ‘camera’ field to true in file ~.poppy_config.yaml

More simply you can use the checkbox enable camera on configure the robot page. It does exactly the same thing.

I don’t know why but when i was trying that, the camera turned off if i restarted the poppy. Now the camera works well with your solution.