The configuration in poppy.conf doesn't work at all!

I’m trying to run Poppy project on my CentOS 7.0, following the README on github site. It did run when i typed poppy-server on the command line, and i could get response when i request with curl --include --request GET --header "Content-Type: application/json" -H 'X-Auth-Token:000' -H 'X-Project-ID:000'

Duplicated file poppy.conf and logging.conf to the .poppy folder, which is in the same hierarchy with poppy projcet folder.

Then the problems came: the configuration in poppy.conf doesn’t work at all! Even when i changed the name of poppy.conf to poppy.conf.backup, poppy-server can run as well. So i tried to find the log file to see what’s wrong. Unfortunately, poppy.log file could not be found in the system, nor server.log name file configured in poppy.conf.

I’ve googled a lot and tried all i can do to solve this problem. Only found that, using poppy-server --debug -v command can print out the debug info on the terminal, and the default configuration of storage and provider are in the boot file poppy/poppy/

But I still have no idea on which config file poppy use and how to log poppy info.

Puppet Developer

It sounds you mix up Poppy project, an open source robotic ecosystem to Poppy, the OpenStack Poppy which is vendor-neutral API for CDN.