Snap on a computer or on Ergo?

I try to run Snap from my computer …here is my process

I run the snap in the robot, i make a project, and i export the project.
Then i run a local snap (on my computer) and i use import to get the project
unfortunately it’s impossible to communicate with ergo_JR.

Is there a solution ?
My aim is to use leapmmotion
on the Snap_ergo, the robot is ok but leapmotion plugged on my computer doesn’t work
On th Snap_computer leapmotion is ok but Ergo doesn’t work !

What i the good way ? Thanks for your help

Hi Luc
when you use your Ergo with an another Snap! (for example this one
just be sure that Jupyter is not active on your robot : it kills the Snap! server, and therefore no communication is possible between your external Snap! and your robot.

To be sure, just power on your robot and run your external Snap! : you don’t need to open the robot-Snap! before.
If you have the right IP of your robot, it MUST work ! :wink:

Hi Gilles Thanks for your help, you put me on the right track.

There is a BUG with external SNAP and import poppy-basic-blocks.xml as we used to do.

The problem is linked to goolge security …

When you try the snap block “url” with :6969
(my robot is on this adress)
in google to the right of the address bar, There is a content blocked icon
In the alert, I click I Load full site.
Now the same block test give me a good answer

But the block setHost answers always
Your robot is unreacheble …

I think that External Snap and poppy-basic-blocks.xml are not comaptible with https securiy of google.

Is there anybody who can explain me how to solve this problem ?

Hi Luc,
breaking news : it’s not your fault.
Everything worked fine until the new version of Snap! 4.1 (at the beginning of February)
Now Snap! needs an httpS connection with Ergo, and Ergo only provides http :frowning:
Yesterday on this post

I explained how to make the Ergo communicate again with external Snap!.
(I had to modify ALL the Poppy blocks)

Here you can find the “new” blocks : poppyblocks_snap4.1.xml (85.7 KB)

It’s not perfect (you still have to click on the shield in the address bar to load insecure content) but so far, I think it is the only way.

Good luck Luc !