PoppyErgoJr connection with Raspberry Pi 4


I am having some issues with my Poppy Robot.
So I have tested the robot with the preinstalled OS : works!
On a Raspbian OS on my Raspberry 4 I have installed the necessary librairies for PpoppyErgoJr and am able to run it in simulation mode.
Where I am having trouble is here:

  • On my Raspbian OS I can’t control the real robot.
    When instantiating the Robot I have the following message:

OS Error: Could not initialize robot : Could not find the motors (1,2,3,4,5,6) on bus /dev/ttyAMA0

The robot is connected through the GPIO Pins on the Raspy to the PoppyBoard.

What am I doing wrong?
Thanks in advance


Hi @mejigu !

If you want to generate your own SD image, please use that script instead that will perform a full install. Otherwise you may also use the image of the v3.0.0alpha here, we are waiting for more feedbacks before releasing it.

Hi @Yoan
Thanks for the quick reply.
Will do that and come back if still not working.
I prefer to use the script and keep my OS as I also need to do other installs on my Rasbpy.

I have run the script and have the same error message.
Do you know of any configuration to be done on the GPIO pins?

Yes a few commands are needed to setup the serial port here, but they’re executed by the script. Did you use the dev_gen2 branch? Raspi 4 is only supported in that branch.

You might want to open a Python terminal and enable the debug outputs in order to get helpful information:

import logging, sys
from pypot.creatures import PoppyErgoJr
logging.basicConfig(stream=sys.stderr, level="DEBUG")
poppy = PoppyErgoJr()

Also attach the install log when you call the script, e.g.:

sudo /tmp/raspoppyfication.sh --branch=dev_gen2 2>&1 > install.log