Ergo Jr with Raspberry 3 B+ not connecting to network

Hi there, I just built an Ergo Jr with a rasberry Pi 3+. I downloaded the latest image 1.34 GB

I tried plugging it into my mac as well as my router and I don’t see it listed on my client list.

The red light on the Pi is just flashing and no light is on the ethernet port.

Any suggestions on where to start looking how to solve this? Thanks!!

UPDATE, I ordered a new SD card and had the same issue. I then downloaded the latest Raspbian OS and burned that to my card… I plugged in my monitor and that seemed to work fine.

Soooo it seems it’s not the power supply, the SD card or the Pi itself… I think the Ergo Jr software isn’t written for a Raspberry Pi 3B+

I noticed in the bill of materials it says use either a Raspberry Pi 2 or 3… I just assumed that also meant the latest 3 B+.

Oh well, I’ll order a 3 and see how it goes

Update, I think it may be my power supply. I ordered a new one… hopefully that’s it!

I got a new power supply and used a multimeter to check the voltage and it was right at 4.95 so it doesn’t seem to be the power supply or cable. I did some more digging and it might be that I’m trying to use sd cards from my cameras etc… I ordered a new SD card. Hopefully that’s it.

Ok I tried it with the Raspberry Pi 3 model B and that works fine! For anyone wondering the Poppy Ergo Jr disk image doesn’t work with Rpi model 3B+.

hello @jeffb

we have some difficulties in correctly integrating all the new features. Especially for lack of time!
Regarding your problem, we have not yet performed any tests on the B+ model. However, you can create your own image by following this procedure:

Sorry for not being able to do more for the moment

I totally understand this is an open source project created by volunteers. It’s been a great project for my son and I to learn together. Thank you!