Problems to id the dynamixels

Vient quand tu veux à l’INRIA, on essayera de te donner un coup de main.

Laura, did you fix it?
I have the same problem.

Hi, it was a long time ago I don’t remember exactly what we did.
But I had to get help from the Inria Team and I think we had to completly reinitialize the Dynamixels.
Sorry I cannot help more. If you contact the Poppy team they should be able to help.

Laura, thanks for your answer.

@Theo it’s a job for you :wink:

Dear @Theo,
I have the same Laura’s problem. We built our Poppy Humanoid and everything it was working (Using ROS with dynamixel motor package and Python with PyPot library). However, from one moment to another, the servos stopped being recognized. I used the Robotis Wizard and the motors were not found. The funny thing is that individually the motors are detected (using Robotis Wizard). Nevertheless, when I connect them in series no longer.
All of them are set in 1Mpbs and with different ID.
Can you help me?

Thanks for your time!


did you update your servo to the last version ? (You should not).
What was changing just before the servo stopped recognizing ? It was a long time ?

No, I did not update the servos. The version of the firmware is 39 for the MX28AT and MX64AT servomotors and 24 for the AX12, all with Protocol 1.0.
I used the robot on Wednesday and everything was working. The next day, Thursday, the problem happened. I did not perform any changes in the experiment setup or in the firmware/software.
At this moment, Robotis Wizard on Windows 10 detects the motors individually (except one MX28). When they are connected (for instance, only the left arm motors, i.e., 4 motors only), Robotis Wizard does not find the motors.

I tried to do a recovery firmware, but the software does not find any motor in this option. I used this tutorial (

In addition, I tried using Windows 10, Windows 7, the USB2dynamixel, USB2AX (both with the drivers installed, where they are detected by Windows as COM3 and COM5).

Ok, did you try to connect all the motors except the MX28 who does not want to connect ? Sometimes, only one vicious motor contaminates all the chain.
Try to connect “only right arm” or “only right leg” … I suspect one motor is bad.
Which MX28 does not work ?

The motor MX28 that it is not being recognized is in the right arm. In the left arm, all motors are detected individually but are not when plugged in series.

In this video I show the problem

Ok cool the video.
Maybe try to change the cable or check it is well connected between 41 and 42.
Otherwise, replace the 42 motor by another one (ankle for instance)

@Thot Thanks for your time.

I checked the cable and it is working. Dynamixel wizard detects the motor 41 using both cables plugged in that motor. I plugged the motors 43, 44 and 41, and they were not recognized.
In this moment, both legs, and only 4 of 5 motors of the torso are detected when plugged in series.

In addition, I tried to perform a recovery manager (video attached) , using one motor at time as indicated by Robotis. However, the motor were not recognized.

When I plugged both legs, 4 of 5 motors of the torso and the motors 43 and 44 of the left arm, only two MX28 servos were recognized. I realized that they appear with different symbols. One of them is green with a red arrow. The other is black. What this means?

Oki, I think we got it ! I had this issue. When a motor is with an arrow (it is a check) it means it works with V2 protocol while the others are in protocol V1. They cannot be on the same line.
When you did the recovery, it was not a real recovery.

You have to downgrade the checked servo motors.
Follow this link :

I wish it ll work :slight_smile:

Dear @Thot,

I tried to perform a recovery firmware. However, the dynamixel wizard does not detect the motor when I use the recovery firmware option. Only, the motor is recognized when I do a search, as shown in this video.

On the other hand, all motors (except motor 52) are detected individually, they have the same firmware version and all of them are detected using the option DXL 1.0.

I really don’t know what other test I can do.

Pypot and usb2ax only works with firmware version 36 on MX. Do you have version 36 or 39 ?
You have to dowload 1.1.3 version of dynamixel wizard to make a recovery to version 36. With the current version of wizard, it is not possible.

@Thot, thanks again for your help.

The Mx28 dynamixel have the firmware 39 ( they came like this when they were bought). They were working with ROS with dynamixel package and Python with PyPot as well using USB2AX.
The humanoid was working with all motors. However, from one moment to another, the servos stopped being recognized.

At this moment, I am using RoboPlus This tool has Dynamixel Wizard
I am doing a firmware recovery in order to get the firmware 36.
When I search the motors individually using USB2AX, dynamixel wizard recognizes the motors.
However, some motors are not found when USB2Dynamixel is used. (Some motors are found).
The recovery firmware only is working in that motors that are found using USB2Dynamixel. This is, using USB2AX the recovery firmware fails in the motor detection. Only USB2Dynamixel works. But, as mentioned, USB2Dynamixel does not detect all motors individually.
In this video I show this problem

Try to connect the motor which is not detected by USB2Dynamixel with USB2Dynamixel and tick Dynamixel V2.0 before detection.
Now the new motors run with firmware 39… good to know !
We have to make tests so that now it is compatible with firmware 39.
I have no access to my Poppy until 5th december.

Hi @Thot,
I tried your suggestion but does not work. :pensive:

Hi @juanjqo
I am running into the same error with my Dynamixel XH540-W270-R. Could you please share the details if you got your Dynamixel working.

Thanks in Advance.

Hi @Gowtham_Ram_Pagadala,

These motors are not working anymore. I tried to perform a recovery firmware or an update firmware, but there is some problem with the IC of each motor. The motors are recognized individually, and it is possible use it. However, when are connected several motors, the communication fails. So, something is wrong with the motors that can not be recovered. You can do the self check and request technical support if necessary.